Bug Crítico En Cisco Data Center Network Manager (DCNM)

Se han descubierto varias vulnerabilidades en la interfaz web de administración de Cisco Data Center Network Manager (DCNM) que permitirían a un atacante remoto robar la cookie de sesión activa saltándose la autenticación, subir archivos, y como consecuencia ejecutar código remoto como usuario root.

DCNM es el sistema de administración de red para todos los sistemas NX-OS que utilizan el hardware Nexus de Cisco en los centros de datos. Se encarga de solucionar problemas, detectar errores de configuración, etc. Por lo que es una parte importante para las organizaciones que utilizan Nexus switches.

La primera vulnerabilidad descubierta (CVE-2019-1619) permite a un atacante robar la cookie de sesión activa sin necesidad de conocer el usuario administrativo o contraseña. Para ello es necesario enviar una petición HTTP especialmente diseñada a un web servlet especifico que se encuentre en los dispositivos afectados.

Versiones afectadas:
– Cisco eliminó el uso del web servlet afectado en la versión 11.1, por lo que afecta a todas las versiones inferiores a 11.1

Por otro lado, la vulnerabilidad clasificada como CVE-2019-1620 se debe a una configuración incorrecta de los permisos en el software DCNM. Aprovechando este error, un atacante podría crear y escribir archivos mediante el envío de datos a un servlet web específico que se encuentra en los dispositivos afectados. De esta manera es posible incluso ejecutar código remoto con privilegio root.

Versiones afectadas:
– En las versiones inferiores a 11.1 de DCNM les afecta este fallo, pero es necesario autenticarse para aprovechar esta vulnerabilidad.
– En la versión 11.1 de DCNM no es necesario estar autenticado para acceder al servlet web afectado y explotar dicha vulnerabilidad.

En la versión 11.2 Cisco elimina la utilización del servlet web afectado del software, con lo que queda parcheada dicha vulnerabilidad.

Por el momento el equipo PSIRT de Cisco no tienen conocimiento del uso malicioso de estas vulnerabilidades hasta el momento. Cisco también recomiendan actualizar a la última versión, indicando en su página web los pasos a seguir.

Más información:

Cisco Data Center Network Manager Authentication Bypass Vulnerability
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190626-dcnm-bypass

Cisco Data Center Network Manager Arbitrary File Upload and Remote Code Execution Vulnerability
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190626-dcnm-codex

New Cisco critical bugs: 9.8/10-severity Nexus security flaws need urgent update
https://www.zdnet.com/article/new-cisco-critical-bugs-9-810-severity-nexus-security-flaws-need-urgent-update/


Via: unaaldia.hispasec.com
Bug Crítico En Cisco Data Center Network Manager (DCNM) Bug Crítico En Cisco Data Center Network Manager (DCNM) Reviewed by Unknown on 2:25 Rating: 5