Vulnerabilidad en Systemd DHCPv6 permite tomar el control remoto de la máquina

El fallo, que es explotable por equipos de la red local, permite la ejecución remota de código debido a un desbordamiento de buffer.

Se ha encontrado una vulnerabilidad en el cliente DHCPv6 incluido en Systemd Network, que afecta a todas las máquinas que hagan uso del servicio de gestión de red de Systemd, y tengan la opción de DHCP con ipv6 activado. Para su explotación, se requiere enviar un paquete a la red local especialmente manipulado, lo que en el mejor de los casos provocará un fallo en el servicio y en el peor, la ejecución remota de código.

El error se encuentra en una incorrecta validación de los datos de entrada, lo que permite provocar un desbordamiento de buffer si el campo ‘server-id’ del paquete tiene una longitud mayor a 493 caracteres. La vulnerabilidad, que ha sido catalogada con el identificador CVE-2018-15688, ya tiene un parche disponible, siendo publicado por el mismo creador de Systemd. La mayoría de distribuciones deberían empezar a ofrecer el parche en los próximos días, si es que no lo han hecho ya. Mientras tanto, una posible opción es desactivar DHCPv6 en el servicio estableciendo ‘dhcp=ipv4’, o estableciéndolo como ‘dhcp=no’.

Systemd es un conjunto de ‘daemons’ que administran el sistema, que ha sido objeto de controversia debido al gran número de funciones que realiza. A día de hoy, la mayoría de distribuciones basadas en Linux lo utilizan, como pueden ser Debian, Red Hat, Arch Linux, etc. A pesar de las opiniones de sus detractores y defensores, un componente tan crítico como puede ser la red, debería estar sujeto a una auditoría de código exhaustiva, el cual no ha sido el caso.

Más información:

Systemd is bad parsing and should feel bad:
https://blog.erratasec.com/2018/10/systemd-is-bad-parsing-and-should-feel.html

CVE-2018-15688:
https://nvd.nist.gov/vuln/detail/CVE-2018-15688

dhcp6 packet size calculation fixes:
https://github.com/systemd/systemd/pull/10518


Via: unaaldia.hispasec.com
Vulnerabilidad en Systemd DHCPv6 permite tomar el control remoto de la máquina Vulnerabilidad en Systemd DHCPv6 permite tomar el control remoto de la máquina Reviewed by Dump3R H3id3gg3R on 6:25 Rating: 5