Una vulnerabilidad en Samba permitía a usuarios sin privilegios modificar cualquier contraseña

Una vulnerabilidad en Samba permitía a usuarios sin privilegios modificar cualquier contraseña

Samba es una implementación software libre del protocolo SMB/CIFS que permite a sistemas Unix y tipo Unix interaccionar en redes de Windows para compartir ficheros e impresoras, además de poder validar usuarios como miembros de un dominio o bien como un domino Active Directory.

Sin embargo, siguiendo la estela de la explotación del mencionado protocolo para atacar sistemas operativos Windows, Samba también fue utilizado para hacer algo parecido contra sistemas Linux, con SambaCry al frente. Los mantenedores del programa software libre han publicado hace poco nuevas versiones para parchear dos vulnerabilidades. Una abría la puerta a lanzar ataques DDoS remotos contra el servidor y otra permitía a un usuario sin privilegios cambiar las contraseñas de otros, incluida la del administrador.

La vulnerabilidad de denegación de servicio, cuyo código es CVE-2018-1050, afecta a todas las versiones de Samba desde la 4.0.0 en adelante y puede ser explotada “cuando el servicio RPC spoolss es configurado para ser ejecutado como un demonio externo. La falta de comprobaciones de sanitación de entrada en algunos de los parámetros de entrada a las llamadas de RPC spoolss podría causar que el servicio de cola de impresión se bloqueara. Si el servicio RCP spoolss se deja por defecto como un servicio interno, todo lo que puede hacer el cliente es bloquear su propia conexión autenticada.”

La segunda vulnerabilidad, cuyo código es CVE-2018-1057, permite a un usuario sin privilegios pero autenticado cambiar las contraseñas de otros usuarios, incluyendo la del administrador, sobre LDAP. Afecta a las versiones 4.0.0 de Samba y posteriores, aunque solo funciona sobre una implementación de Controlador de Dominio de Active Directory de Samba. El origen estaba en que este componente no estaba validando correctamente los permisos de los usuarios cuando solicitaban modificaciones de contraseñas a través del LDAP.

Samba suele venir incluido en los repositorios de las distribuciones Linux y resulta fácil de utilizar, al menos a nivel básico, en Ubuntu y openSUSE. Sus mantenedores han anunciado que las versiones 4.7.6, 4.6.14 y 4.5.16 incluyen los parches contra las vulnerabilidades descubiertas, aunque a los que usen las implementaciones suministradas por los repositorios de las distribuciones Linux les tendría que llegar vía actualización estándar del sistema.

Fuente: The Hacker News


Via: www.muyseguridad.net
Una vulnerabilidad en Samba permitía a usuarios sin privilegios modificar cualquier contraseña Una vulnerabilidad en Samba permitía a usuarios sin privilegios modificar cualquier contraseña Reviewed by Lydecker Black on 8:45 Rating: 5