Actualiza SAMBA para protegerte de estas dos nuevas vulnerabilidades: una que permite ataques DoS y otra que permite cambiar la contraseña de cualquier usuario

SAMBA es una implementación del protocolo SMB de código abierto que permite compartir archivos dentro de una red local sin las principales limitaciones de SMB, siendo compatible con prácticamente cualquier sistema operativo moderno, como Windows, Linux e incluso Android. Sin embargo, para poder garantizar nuestra seguridad es necesario asegurarnos de estar utilizando la última versión de este servidor, sobre todo después de las dos últimas vulnerabilidades que se acaban de dar a conocer.

Hace algunas horas, los desarrolladores de SAMBA lanzaban una nueva versión de su servidor, una actualización centrada principalmente en corregir dos nuevas vulnerabilidades de alta peligrosidad recién detectadas en el servidor de este protocolo.

Las dos vulnerabilidades de SAMBA

La primera de las vulnerabilidades ha sido registrada como CVE-2018-1050. Este fallo de seguridad afecta a todas las versiones de Samba desde la 4.0.0 en adelante, y puede explotarse muy fácilmente para detener cualquier conexión establecida con el servidor, causando lo que se conoce como denegación de servicio.

El segundo de los fallos de seguridad sí que es bastante más peligroso que el anterior. Este fallo, registrado como CVE-2018-1057, permite a cualquier usuario autenticado en el sistema, aunque no tenga permisos en él, cambiar la contraseña de cualquier usuario del servidor SAMBA, incluida la contraseña de la cuenta de administrador.

Esta segunda vulnerabilidad también existe desde SAMBA 4.0.0, y solo se puede explotar a través de Samba Active Directory DC, por lo que si usamos LDPA el usuario sin permisos no podría cambiar las contraseñas.

Cómo podemos protegernos de estas dos vulnerabilidades en SAMBA

El alcance de estas dos vulnerabilidades es muy grande debido a que este servidor viene instalado en la mayoría de las distribuciones Linux, distribuciones que ahora mismo son vulnerables a estos fallos de seguridad.

Las versiones de este servidor que cuentan con soporte son las ramas 4.5, 4.6 y 4.7, por lo que los responsables de SABA han lanzado las versiones 4.5.16, 4.6.14 y 4.7.6 que ya solucionan estos graves de seguridad y nos permiten hacer uso de este protocolo de red de forma segura, sin peligro.

Cómo actualizar SAMBA en nuestro equipo o servidor

Si esta nueva versión aún no está disponible no tardará en aparecer en los principales repositorios de las distribuciones, por lo que simplemente actualizando nuestro sistema (utilizando comandos como “apt update && apt upgrade”, si el sistema está basado en Debian, por ejemplo) podremos descargar los últimos paquetes de software, entre los que se incluirá la última versión de esta aplicación.

Si no queremos esperar, o por algún motivo no nos aparece esta nueva versión del servidor, siempre podemos descargar la última versión disponible desde su página web principal.

¿Utilizas SAMBA? ¿Has actualizado para protegerte de estas vulnerabilidades?


Via: www.redeszone.net
Actualiza SAMBA para protegerte de estas dos nuevas vulnerabilidades: una que permite ataques DoS y otra que permite cambiar la contraseña de cualquier usuario Actualiza SAMBA para protegerte de estas dos nuevas vulnerabilidades: una que permite ataques DoS y otra que permite cambiar la contraseña de cualquier usuario Reviewed by Lydecker Black on 9:29 Rating: 5