WinRAR no pudo parchear una vieja vulnerabilidad porque código fuente ya no existe

WinRAR es uno de los programas para Windows más descargados de la historia, acumulando ya miles de millones de descargas. Sin embargo, el programa lleva casi 19 años teniendo una vulnerabilidad.

Han sido investigadores de Check Point los que han publicado los detalles técnicos de esta vulnerabilidad en WinRAR, que afecta a todas las versiones lanzadas en los últimos 14 años. El fallo se encuentra en una librería de terceros llamada UNACEV2.DLL. Esta librería permite descomprimir archivos que están comprimidos usando el formato ACE. La última versión compilada es de 2006 y la aplicación WinAce original permanece discontinuada desde 2007.

El problema reside en que WinRAR detecta el formato de los archivos basándose en su contenido, y no en la extensión, por lo que simplemente pueden cambiar la extensión .ACE a .RAR para que parezca un archivo normal de WinRAR. El fallo permite a un atacante ejecutar código arbitrario en un ordenador que intente descomprimir el archivo siempre que se usen versiones vulnerables del programa, en un fallo conocido como "Absolute Path Traversal".
Gracias a este fallo, el atacante puede elegir la ruta en la que quiere que se descomprima el archivo, independientemente de la que haya elegido el usuario. Los investigadores demuestran esta función descomprimiendo el archivo en el escritorio, pero en realidad se está creando un archivo malicioso en formato .EXE en Inicio, de tal manera que cuando el ordenador se encienda, el archivo se abrirá automáticamente.

La solución de WinRAR: eliminar la librería

La librería UNACEV2.DLL fue incluida en WinRAR en 2005, pero el equipo de WinRAR ha perdido el código fuente de ella, por lo que la solución por la que han optado es borrar directamente el archivo para arreglar el fallo. A partir de la versión 5.70.1 Beta 1, el archivo ya no está presente y la vulnerabilidad está solucionada. La consecuencia directa de esta "solución" es que WinRAR ya no es compatible con archivos en formato .ACE, aunque era un formato que ya prácticamente no se utilizaba.

Por ello, si eres usuario de WinRAR, os recomendamos que instalar la última versión del programa, ya que es probable que haya atacantes que ya estén al tanto de la vulnerabilidad y escondan archivos maliciosos dentro de archivos en formato .RAR.También existen una gran cantidad de compresores alternativos muy superiores en prestaciones y características, como PeaZip o Bandizip, dos grandes alternativas gratuitas (y la primera, además, OpenSource) que nos permitirán trabajar con ficheros RAR y RAR5 sin ningún problema.

Este tipo de vulnerabilidad se paga muy bien por empresas como Zerodium. En el caso de no haber decidido publicarla, Check Point podría haber recibido hasta 100.000 dólares por esta vulnerabilidad de día cero.

Fuente: Check Point

Via: feedproxy.google.com
WinRAR no pudo parchear una vieja vulnerabilidad porque código fuente ya no existe WinRAR no pudo parchear una vieja vulnerabilidad porque código fuente ya no existe Reviewed by Unknown on 9:25 Rating: 5